Main Menu

Electrical

Radio for 914-6

Porsche Classic Radio Navigation

1973 914 electrical issues

My left turn signal lights up both left and right turn lights.  My gas guage does not go above 1/4 full.  Both problems were the result of an un-named mechanic "fixing" a wire.

In any case, I am trying to correct this and need the correct wiring diagram.  Where can I find the model # of my 1973 914 1.7L car in order to find the correct wiring diagram?  

Also, do you have any recommendations on how to go about troubleshooting this find the issue.  

I appreciate any help you can provide.

thank you

Herb

1973 914 gage lights dim

The gage lights in my 1973 914 are dim. What causes this and how can it be repaired?

 

Electrical

What side is the ignition switch on?

vdo gauges

Model: Porsche, Year:1975, Mileage:120000, Type of use:Both Street & Track
I have a 1975 914 and I think the oil temperature gauge is shorted out. I mistakenly put the power wire on the ground. Now the needle pegs out to max. as soon as I power it up. Do you know how to repair these or a place that would repair the VDO oil temperature gauge? This is the combo gauge in which 4 screws takes out the oil temp unit.

ignition

Model: 914, Year:1971, Mileage:110K, Type of use:Both Street & Track

Intermittant wipers

Model: 914, Year:1975, Mileage:90,000, Type of use:Street use only

Wiper speeds

Model: 914, Year:74, Mileage:179000, Type of use:Street use only
recently had a new three speed wiper installed on a 74 2L. Works fine with the exception that it still runs when in the parked/off position. Have to move the handle up and down until wipers will park off. While the wipers are parked I can hear the intermittent cycle clicking. Have also blown the #8 fuse twice while trying to park the wipers.

driver side running lights blowing fuse

Model: 914 2 liter, Year:1975, Mileage:120 k, Type of use:Street use only
When I turn on the parking lights the fuse blows.I tried removing all the blubs even disconnected the rear tail light wires.same result. Any ideas where to go from here? Thanks Rick

Tachometer 914

Model: 914-4, Year:1974, Mileage:133K, Type of use:Street use only
I got the wiring answer from Ed Mayo, still not getting operation of the tach. I Checked that there is power (yes), signal (yes), and good ground (yes)What could I be missing?

Pages

Subscribe to RSS - Electrical