Main Menu

1973 911T MFI Switch

Engine

Vehicle Information: Model: 911 T; Year: 1973; Body Type: Targa; Engine (type, size, modifications): 2.4 standard; Total Mileage: 140,000 ;

Since my last question to you regarding setting up the MFI, the car has run flawlessly. However, over the past couple of days, when the car is warm, the revs have hung up at 1800-2200 when you decelerate. If you de-clutch, the revs will hang and then fall down to about 1200. It seems that when the car is cold and warming up it idles strongly at 1000 rpm. Once warm /hot it idles higher and hangs up on the way down. I thought that it was the solenoid on the side of the velocity stacks, however when i adjusted the screw, it did not give the drop in revs like normal. I have assumed that this solenoid has been faling recently and finally gave up today? The other factor is that if i rev the car using the accelerator, it hangs up on the way down really bad; if i use my hand to move the linkage back and forth( pushing it to close the throttle) it does not hang up returns swiftly to 1000 rpm. I think therefore that the linkage system needs a good clean up and some new springs. Do you know who supplies that solenoid and the springs? Is it porsche only? I would be very grateful for any advice/ part no.s. What lube would you recommend for the ball joints?In previous MFI replies you have mentioned a solenoid that breaks which people do not replace because it is $150. Is this the same one? Grateful for any assistance; the help you gave last time sorted my car out in about 5 mins!!Cheers, Rich Waller

You must log in to view answers associated with technical questions. Join PCA to participate in our community.
No votes yet