Main Menu

1987 944 Engine miss

Fuel System

Vehicle Information: Model(924/944/968): 944 NA; Year: 1987; Body Type: Coupe; Total Mileage: 145000;

The car appears to be running lean. From low to mid rpms (1000-4500 rpm)there are hesitations or misses and appears to be a little down on power. As soon as you unplug the O2 sensor it runs great. My understanding is that by unplugging the O2 the DME defaults to full rich. So I am pretty sure it is fuel mixture related not ignition or fuel delivery. I have replaced the: Plug wires and plugs Replaced the O2 Sensor Replaced both reference sensors Replaced the Throttle Position Sensor Rebuilt the throttle body Replaced the DME Temp Sensor Replaced almost all the vacuum hoses Took the MAF apart and clean the surface and adjusted the pickup and checked voltage output The DME (rebuilt by "Python") and relay were replaced by previous owner three years ago Purchased new fuel filter (current appears to be original) but have not installed yetThe only thing left as far as I can tell is the MAF is bad. Needless to say I am a little tired of replacing things that have not helped. Everything I replaced appeared to be original so it is not the end of the world that it was replaced without curing my problem but is getting old. Before I plunk down $200-300 more for a rebuilt MAF I was hoping to see if you have any other suggestions or if maybe I am barking up the wrong tree. Any suggestions are greatly appreciated.

You must log in to view answers associated with technical questions. Join PCA to participate in our community.
0
No votes yet