Main Menu

1988 944 compressor clutch not engaging...

  • 1988
  • 944S
Mileage: 
118 000
Other
Piedmont, 
South Carolina

Hi Members,
    I have a problem with my A/C. One day, I was driving along with the A/C on then it cut off. I did some research online and found that I could diagnose whether the compressor was good or not. I applied 12dcv to the compressor clutch and it engaged. Then I removed the climate controller to inspect it. Turned out that the circuit board was literally burned out. I also have a 1994 968 out of which I removed its climate controller and installed it into the 944. I immediately had A/C again. The next day I drove my wife and I to church and, in about 10 minutes, the A/C started feeling weak. Then I realized the A/C had quit again. Once back home, with the engine still running, I popped the hood and asked Heather to press the A/C's ''snow flake'' button. The clutch did not engage. On Monday, I applied 12dcv to the clutch and, again, it engaged. I started the car and, while having the clutch manually engaged still, I turned on the climate controller's fan and it was blowing out cold air. I disconnected the wire from the battery to the compressor's clutch and pressed the ''snow flake'' button; no cold air. I removed the climate controller but I haven't taken its back cover off yet to check for any signs of burnout. There were no odors to indicate a burnout. I then removed the glove box and found the 2 thermostats (I suppose 1's for A/C and 1's for heat?) I discovered that the bottom thermostat was really hot to the touch; whereas, the upper one felt like room temperature. I think that something could be wrong with the lower thermostat. I looked at  fuse #27 (for the A/C) was rated at 30amp. I had read that it should be 7.5amps and that, at most, should be a 10amp. It was further said that if the compressor was running/working too hard, it would easily blow a 7.5 fuse; yet, if more than 10amp was in that the compressor could cause the ''snow flake'' switch to burn out. Since I had bought the car with the 30amp, I don't know if a prior mechanic had replaced it to experiment with a much higher amped fuse to elimate the blowing fuses problem (?) and, if, the compressor might have needed replacing (though it's coming on when I jump it). Is there a way to ohm out the climate controller to test and see if the ''snow flake'' switch is burned out or if it's still good and if the A/C could be having bad windings? I'd hate to buy and install (another) climate controller and jeapordize burning it out. Any thoughts on whether the lower thermostat is defective? What else I should diagnose? Thanks, Todd    

You must log in to view answers associated with technical questions. Join PCA to participate in our community.
0
No votes yet