Main Menu

1997 993 Cabriolet C2 Engine Fan Belt light on and off

Engine

Vehicle Information: Model: 993 C2; Year: 1997; Body Type: Cabriolet; Total Mileage: 72600;

I had this car for 2.5 years and about 5 miles now. I do not think any belts were changed in the last 4 years or 10K miles. After this weekend hard driving for about 2 hrs (rpms over 5000 at times) when stopped and restarted the car after 20 minutes the warning light for Engine Fan Belt did not come off. I visually inspect the belts, checked tension (with a "thumb" method) and all seemed OK. I still had some 150 miles to go and decided to go rather than get stranded on a Saturday night... I drove making sure the rpm are not over 3000. For the first 10 miles the light stayed on for some time, came off and on a few times. Than OK for say 50 miles, then again stayed on and off for some time but the last say 60 miles, the light did not come on again. During this trip I stopped a few times to check the belts and have not noticed anything suspicious. There is nothing I did during this trip that was unusual - although I did drive it very hard - driving over 5000 for few minutes at a time, hard acceleration with rpms close to 6000 before changing gears etc. I did top off oil just before the trip (not sure if say a particle of oil spilled would cause say minimal slippage etc.). Appreciate your ideas on the cause and possible fixes.

You must log in to view answers associated with technical questions. Join PCA to participate in our community.
No votes yet