Main Menu

2003 996 C4S Complete loss of anti freeze and overheat with low oil pressure

Engine

Vehicle Information: Model: 996C4S; Year: 2003; Body Type: Coupe; Total Mileage: 23266;

I'm in Tucson, AZ on a business trip and decided to drive to Mt. Lemon. At the top of the mountain, I get a "CHECK ENGINE COOLANT" message flashing in red. I pull over and noticed the car was steaming from the engine area and noticed a trail of fluid and a rather large puddle of anti freeze protruding from the rear of the car. Luckily I was at the general store parking lot when this happened.I went in and bought 2.5 gallons of water and decided not to pull the reservoir cap off because I started to have a crowd gather and did not want to risk injury to anyone. I looked at the reservoir and fluid was at the min mark.I noticed the engine was covered with anti freeze and let the engine cool down and got on my way. I was about six miles from the store when I started to get the engine overheat and low oil pressure indications and every time I pulled over and shut my car down. The 2.5 gallons of water went fast and I had to baby my car until I was out of the mountains so I could get more water for the engine. I get to a station and get water and try to drive it to a safer area to call when the lights came on and no oil pressure then the engine shuttered and the car stalled. I was in a safer area luckily and could call for help. Now, my car starts fine but I'm not driving it and I'm having it towed to the Tucson dealer to be worked on. What caused the fluid loss and do you think the engine is damaged?TIA

You must log in to view answers associated with technical questions. Join PCA to participate in our community.
No votes yet