Main Menu

914 1.7 Engine cutting out

Engine

Vehicle Information: Model (914/4, 914/6): 914/4; Year: 1973; Engine (type, size, modifications): 1.7; Total Mileage: 180000;

About four months ago I was having problems with the engine cutting out at both high and low RPM, and at times completely stalling. I did a complete tune up checking everything from the valves to replacing the points and condensor, ignition timing, plugs, air filter, fuel filter, oil and filter. I checked all hoses for vacuum leaks and intake runners and gaskets. Afterwards it slightly did the same thing but it then went away. Well it's been four months and now it's back, and it is stalling when I let off the gas coming to a stop and cutting out or bucking at low and high RPM. I found resistance values at Rennlist for all fuel injection componets and all tested within limits except for the head temp sensor because I couldn't get to it without removing alot of stuff. I have also rechecked the points and dwell angle and timing all is good as are the plugs and leads. The cap and rotor are also good. I know there is fuel pressure because after it dies while cranking the engine to get it restarted after 30 seconds ar so I can smell fuel it's just not being ignited. When I go to the back and check all connections everything seems to be fine and then the car will restart. This problem is very intermittent, it will happen and then be perfectly in order for many miles but occur again intermittently. I also don't think it's vapor lock because the outside temperature is 35-50 degrees when it happens. I suppose there is a fault in the wire harness somewhere but I can confirm voltage at the coil from the ignition switch. What else could it be. Any thoughts would be greatly appreciated.

You must log in to view answers associated with technical questions. Join PCA to participate in our community.
No votes yet