Main Menu

Rough running

Fuel System

Vehicle Information: Model: 911T; Year: 1969; Body Type: Coupe; Engine (type, size, modifications): 2.0; Total Mileage: 70,000 +;

This is similar to another question you answered on 7/17/2004 for another member. After taking my car out from it's winter storage (I took all of the normal put away steps, full fuel tank, etc)it ran well for the first few miles then started running very rough, particularly bad under load (going up hills) to the point of not being able to get up one steep one. I removed the "after pump" filter and noticed it quite dirty so replaced it. It ran OK for a few miles again and the same thing happened. The filter seemed a little dirty again so I removed the tank and had it cleaned (I'm assuming that would have cleaned the mesh filter you spoke about in your above response). Again it ran OK for a few miles and started running as if on half its cylinders and I could barely get it home. I took the pump off with the intension of cleaning it's internal filter but it isn't a Bendix as specified in the shop manual and it wasn't easy to see how to get it apart. I didn't make note of the name but believe it was Hendrix or? and made in Germany.The car also backfires a bit (popping sound). Have you any suggestion as to what my problem could be and some suggestions at a solution? Saint John is a great place to live but not if you own an older Porsche, as the closest dealership is a 5 hour drive.Thanks in advance.Bruce Stevens

You must log in to view answers associated with technical questions. Join PCA to participate in our community.
No votes yet